Altova User Forum


Important: this is not a Support Forum! Experienced users might answer from time to time questions posted here.
If you need a professional and reliable answer, or if you want to report a bug, please contact Altova Support instead.

Exporting from 2004 rev3 to Access 2003 Options · View
ntm1275
Posted: Wednesday, November 12, 2008 1:01:40 AM
Rank: Newbie

Joined: 11/12/2008
Posts: 1
Location: UK
When I export from XMLSpy 2004 rev 3 to Access 2003, it creates all the tables with Primary and Foreign Keys, but the Keys are out of synch on two tables
e.g
1
2
3
4
5
10
11
12
13
6
7
14
15
16
8
9

It only does this with 2 tables, but the corresponding key 5 in table one and key 5 in table two do not match the information from the XML file
e.g
Primary Key 5 is for a person called Tom Jones in table one, but Primary Key 5 is for a person called Betty Smith in table 2
The structure of the XML file is in the picture below - the offending sections are NAWPupilIdentifiers and NAWPupilStatus, the other 2 export OK

http://ntm1275.f2s.com/pictures/xmlpicture.jpg

If I ask it to export to a Text File, it works fine

Is this a bug in the version I'm using or am I doing something wrong
I have tried the 2008 evaluation version and it works perfectly in that

Any help would be appreciated
paul
Posted: Tuesday, February 03, 2009 8:11:29 AM
Rank: Advanced Member

Joined: 9/9/2005
Posts: 469
Location: AT
Hello,

From your description it sounds as if this may have been a bug in that version of the software, now fixed. However, if you contact us with your files via the Support Center, we will be happy to verify things.
Users browsing this topic
guest

Forum Jump
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Use of the Altova User Forum(s) is governed by the Altova User Forums Terms of Service.

Please note that the Altova User Forum was launched so that our users have the possibility to interact and exchange their experiences regarding Altova's product line with one another. It must be pointed out that our support engineers and software engineers regularly post answers to questions in the user forum as an extra service, however this is not a replacement for the regular support mechanism and we cannot in anyway guarantee that a question will be answered or give a specific timeframe for an answer.The user forum was not intended to replace the online support form, but was implemented as an additional source of information after repeated requests for a user based forum in which users can help one another.